Aktuálně: Postihly zákazy tvou profesi? Poptávka po ajťácích prudce roste, využij slevové akce 30% výuky zdarma!
Pouze tento týden sleva až 80 % na e-learning týkající se PHP
Discount week - April - 30

9. diel - Vzorce, funkcie a adresovanie v programe Excel 3

V minulej lekcii, Vzorce, funkcie a adresovanie v programe Excel 2 , sme si ukázali relatívnej adresovanie, hromadné výpočty, zmiešané adresovanie a argumenty funkcií. Táto tretia lekcia v minisérii o vzorkách, odkazoch a adresovanie predstaví doteraz nepopísané zaujímavé možnosti využitia funkcií.

Vnáranie funkcií

Koľko funkcií sa zmestí do jednej bunky? Správna odpoveď je opäť nekonečno, alebo niečo podobné, a to z toho dôvodu, že funkcie môžeme do seba vzájomne Vnorovy, a potom sa hodnota vnorené (vnútorný) funkcia stáva argumentom funkcie vonkajšie.

Medzi jednoduchšie príklady patrí napríklad tento spôsob súčtu hodnôt v bunkách:

=SUMA(SUMA(A1:A2);SUMA(A3:A4)). Tento výpočet môžeme označiť ako "sumu sum", kedy sa najprv vyhodnotí dva vnútorné súčty a tie sa potom navzájom spočítajú. Opäť sa bavíme čisto akademicky, pretože toto je dosť nepraktické.

Iná je situácia s funkciou KEĎ, ktorá je učebnicovou funkcií pre vnorovanie. Platí totiž, že jedna funkcia IF môže pojať len jedno kritérium (podmienku), a to je mnohokrát nedostatočné. Trebárs keď si povieme, že voda pod 0°C je vo forme ľadu a nad 100°C je vo forme pary. Ako by sme toto previedli do reči Excelu?

Potrebujeme funkciu KEĎ do seba vzájomne vnoriť. Platí, že **počet intervalov (tu 3) je vždy o


 

...koniec náhľadu článku...
Pokračuj ďalej

Vedomosti v hodnote stoviek tisíc získaš za pár korún

Minul si až sem a to je super! Veríme, že ti prvé lekcie ukázali niečo nového a užitočného.
Chceš v kurze pokračovať? Prejdi do prémiové sekcie.

Obmedzená ponuka: Nauč sa všetko a ušetri

Kúpiť lekcie a funkcie postupne a po jednom 320 bodov
Kúpiť všetky aktuálne dostupné lekcie s funkciou odovzdávanie úloh za exkluzívnu cenu 272 bodov (678 Kč)
Na svojom účte máš aktuálne 0 bodov
Kúpou tohoto výhodného balíčku získaš prístup ku všetkým 38 lekciím s kontrolou a certifikáciou a ešte naviac ušetríš 120 Kč. Ponuka je obmedzená len pre prvé lekcie z kurzu a obsahuje exkluzívnu zľavu 15%.
272 bodov získaš za pridanie svojho článku na sieť alebo za 798 Kč 678 Kč

Pozor, pokiaľ si kúpiš len tuto lekciu, stratíš nárok na špeciálnu zľavu 15% na balíček všetkých lekcií.

Kúpiť len lekcii 10 bodov
Na svojom účte máš aktuálne 0 bodov
10 bodov získaš za pridanie svojho článku na sieť alebo za 25 Kč

Obsah článku spadá pod licenciu Premium, kúpou článku súhlasíš so zmluvnými podmienkami.

Čo od nás v ďalších lekciách dostaneš?
  • Neobmedzený a trvalý prístup k jednotlivým lekciím.
  • Kvalitné znalosti v oblasti IT.
  • Zručnosti, ktoré ti pomôžu získať vysnívanú a dobre platenú prácu.

Popis článku

Požadovaný článok má nasledujúci obsah:

Toto je posledná lekcia na tému vzorcov a funkcií. Zoznámime sa v nej s vnáraním funkcií, operátorov a zástupnými znakmi, maticovými funkciami a poloadresováním.

Body získaš, keď podporíš našu sieť. To môžeš urobiť buď zaslaním symbolickej sumy na podporu prevádzky alebo pridaním obsahu na sieť.

Článok pre vás napísal Petr Svoboda
Avatar
Petr
Aktivity (1)